Author Topic: Post-spam wiki acceptance testing  (Read 697 times)

0 Members and 1 Guest are viewing this topic.

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Post-spam wiki acceptance testing
Everyone who is an active user or editor of the wiki, please check to see that nothing was inadvertently deleted in the spam purge.

The procedure I used was supposed to only delete spam users and any revisions they made, but it's possible that something went wrong, so I need everyone to tell me if they see anything amiss.

One thing I noticed just recently is the Community Portal page.  Did that have text on it previously?

EDIT: According to Discord, it did.  I'm re-running a modified de-spamming procedure.

EDIT2: The page still exists in the database, but the link doesn't work.  Investigating.
« Last Edit: March 07, 2018, 08:55:29 pm by Goober5000 »

 

Offline DahBlount

  • 29
  • Alpine ☆ Cancer Tribulation
    • Minecraft
    • Skype
    • Steam
Re: Post-spam wiki acceptance testing
It seems as though one of pages doesn't have the 'p' in portal capitalized?

This link seems to be the correct page: http://wiki.hard-light.net/index.php/FreeSpace_Wiki:Community_Portal
<Axem> yet still more insightful than #hard-light

<Axem> jad2.23 will just be cat videos

<DahBlount> So
<DahBlount> JAD2.2 is like that
<Axem> maybe
<Axem> it can be whatever you like!
<DahBlount> A Chocolate Sundae?
<Axem> sure

My models: GTF Gilgamesh - GTD Nuadha [Redesigning] - Ningirama [WIP] - GTG Zephyrus

  

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: Post-spam wiki acceptance testing
The first-level problem was the difference in case, as you noticed, but digging more deeply, the MediaWiki default URL was different from our actual URL.  It's possible to override the default by using a custom metadata page, but this page was deleted in 2007 as being unnecessary.  Not sure how it worked from 2007 to 2017; maybe the default changed when the MediaWiki engine was upgraded. :confused:  This also doesn't explain why our page's URL was different from the default in the first place. :confused:

Anyway, I restored the old metadata page, and the link works now.

 

Offline Vidmaster

  • 211
  • Inventor of FS2 bullettime ;-)
Re: Post-spam wiki acceptance testing
Aside from the "missing thumbnail" errors, various other images are now missing entirely without that error.

- User Made ships for instance (http://wiki.hard-light.net/index.php/User-made_Ships) is missing all the small icons.
- some ship pages still have the error, such as http://wiki.hard-light.net/index.php/GTGs_Titan ...
- ...while this one http://wiki.hard-light.net/index.php/GTC_Rhea shows no thumbnail-error but still no image
Devoted member of the Official Karajorma Fan Club (Founded and Led by Mobius).

Does crazy Software Engineering for a living, until he finally musters the courage to start building games for real. Might never happen.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: Post-spam wiki acceptance testing
Well, this thread was supposed to be specifically about spam, but since that appears to be solved, we can make it about the thumbnails too.

The thumbnail issues should be fixed, per the news post.  Take another look now.

 
 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Re: Post-spam wiki acceptance testing
Good job spotting that.  I investigated further and I discovered that my spam cleanup method didn't catch pages that had been created by anonymous accounts.  Most of those were listed in the Orphaned pages section, so I just went through and deleted a bunch.

That doesn't mean I got them all, of course, but I just looked through the pages with 1 revision on the Pages with the fewest revisions and didn't see any.