Author Topic: Joystick No Worky  (Read 149 times)

0 Members and 1 Guest are viewing this topic.

Offline QuakeIV

  • 28
So, yes I checked other campaigns and my joystick still works fine for those, it does seem to be isolated to Inferno.  Just figured I'd mention this since I have the most generic Logitech joystick ever (extreme 3d pro) so it might be effecting more people than just me.

 
I think I had this problem with exile before in knossos...go into "details" then "FSO settings" in options and select said build. That should solve things...make sure you save the changes too

 

Offline QuakeIV

  • 28
Its got the latest nightly selected in there like the release post asked for, if thats what you mean.

 

Offline ngld

  • 29
This is a known bug and I'm working on a fix. The problem is that recent FSO nightlies use a newer version of SDL which generates different GUIDs for the same device. You can workaround this bug either by editing the fs2_open.ini manually (the correct GUID is logged in fs2_open.log) or replacing Knossos' SDL2.dll with the one found in the nightlies.