Author Topic: Resolution issue  (Read 5911 times)

0 Members and 1 Guest are viewing this topic.

Hi All,

Sorry if you've had this 100 times before, but I'm new to modding and only just got back into PC gaming after a ~15 year hiatus.

I've installed Freespace 2 and FSO and also the MediaVPs mod for the amazing hi res textures. Problem is that when I load into a mission it cuts a chunk off the side of the screen. Essentially I can see up to the edge of the energy management guages (GSE) but not the amount of missiles I have or the other wings etc.

I've been frantically searching for a fix but can't find anything which is quite the same issue. I feel relatively sure it's because I'm playing on a 60" 4K tv but other games I play like Overwatch play fine. I've tried a whole host of resolution settings but most render the game unplayable.

Can anyone offer some assistance. I need my nostalgia kick.

 

Offline Novachen

  • 28
  • The one and only capella supernova
What Operating System you are using?

Because you are using a very high resolution, it is possible that the automatic scaling by Windows 8/10 is active. But afaik FSO will also still be scaled with values that are different from 100%.

So try to change your scaling in Windows to 100% through the general display settings. Maybe that helps.
Female FreeSpace 2 pilot since 1999.
Global moderator in the German FreeSpace Galaxy Forum.

Responsible for the german translation project FreiRaum - FreeSpace auf Deutsch.
Also responsible for the Nova Upgrade Project, which upgrades and fix older campaigns to make them play- and solveable again with current builds and MediaVPs.

Release List:
German Translations:
Between the Ashes 1, FreeSpace Port, Silent Threat: Reborn, The Destiny of Peace, Awakenings & Deneb III.

Nova Upgrades:
A Walk in the Sun, Into the Halls of Valhalla, Luyten Civil War, Renegade Resurgence, Rogues!, Storm Front Saga, The Deuterium Connection & Venice Mirror.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
I think FSO has trouble dealing with 4K resolutions. It's a known problem but hasn't been fixed yet since none of the coders can run the game in 4K.

Please post your fs2_open.log file.  Instructions on how to do this can be found in this post. It might help diagnose the problem further.

 
What Operating System you are using?

Because you are using a very high resolution, it is possible that the automatic scaling by Windows 8/10 is active. But afaik FSO will also still be scaled with values that are different from 100%.

So try to change your scaling in Windows to 100% through the general display settings. Maybe that helps.

Alas I have tried this, it didnt fix the issue and made my computer practically unusable because it was so small.

Thank you for your help though, it is much appreciated.

 
I think FSO has trouble dealing with 4K resolutions. It's a known problem but hasn't been fixed yet since none of the coders can run the game in 4K.

Please post your fs2_open.log file.  Instructions on how to do this can be found in this post. It might help diagnose the problem further.

Thank you for helping. I'll post my debug log once avast has decided to stop being a jerk and let me run the fast debug.  :lol:


 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
What Operating System you are using?

Because you are using a very high resolution, it is possible that the automatic scaling by Windows 8/10 is active. But afaik FSO will also still be scaled with values that are different from 100%.

So try to change your scaling in Windows to 100% through the general display settings. Maybe that helps.

I think you can disable it for only specific programs by going to the .exe, right-click, properties, compatibility, change high DPI settings