Author Topic: Problems with UI Text  (Read 538 times)

0 Members and 1 Guest are viewing this topic.

Offline Madrox

  • 27
  • Because destroying shivans ins´t enough...
    • My DeviantArt
Problems with UI Text
So, I´ve recently reinstalled FS2 and FSO through Knossos and saw a bunch of nice stuff, including my old favorite, Wings of Dawn, but the problem is, after launch WoD through Knossos, i get a problem, the game runs well (though slowly) but then i can´t see any text at all. Below is the log i got from running the fast debugger (Interestingly, when i run the game on the debugger, the texts all work fine):

https://fsnebula.org/log/5c2be807cb0d335ccd4f9b6e

How can I fix this? Thanks.

edit: the in-mission texts work.

[attachment deleted by admin]

 

Offline Axem

  • Administrator
  • 211
Re: Problems with UI Text
Code: [Select]
OpenGL Renderer  : AMD Radeon R7 M265
I think your video card is your problem. There's been some reports about older AMD cards having issues with TTF fonts (the ingame fonts are the older fonts, so that's why those work). That's an engine problem and not really a mod problem, so our ability to fix it is up to a coder being able to have the same hardware to reproduce it... which no one does at the moment. :(

But that's very interesting that in a debug build the text would be fine...

 

Offline Madrox

  • 27
  • Because destroying shivans ins´t enough...
    • My DeviantArt
Re: Problems with UI Text


I think your video card is your problem. There's been some reports about older AMD cards having issues with TTF fonts (the ingame fonts are the older fonts, so that's why those work).

Interesting that you say that, because my AMD card shouldn´t be working, the drive is corrupted due to a hardware issue which im going to fix soon, but then, why can i play FS2 with MediaVPS with texts working? Anyway, I think i know how to fix this.

edit: Yep, i´ve fixed it by disabling my amd driver mannualy so now its forced to use my on-board card. Thanks for pointing that out, i thought it was something about the files.

 

Offline Axem

  • Administrator
  • 211
Re: Problems with UI Text
Noooo idea. Glad you managed to find a way to make it work though!

 

Online ngld

  • Administrator
  • 29
  • Knossos dev
Re: Problems with UI Text
The MediaVPs don't use TTF fonts which means that they can't trigger this bug.

 

Offline Madrox

  • 27
  • Because destroying shivans ins´t enough...
    • My DeviantArt
Re: Problems with UI Text
The MediaVPs don't use TTF fonts which means that they can't trigger this bug.

Well, im going to fix my dedicated amd card soon, what i do, then? Is there a way to manually change the fonts the game uses as a workaround?

 

Offline Axem

  • Administrator
  • 211
Re: Problems with UI Text
I may have a solution for that. When you have your AMD card working and it's still unable to display text, PM me and I'll get you to test something. :)

 

Offline Madrox

  • 27
  • Because destroying shivans ins´t enough...
    • My DeviantArt
Re: Problems with UI Text
I may have a solution for that. When you have your AMD card working and it's still unable to display text, PM me and I'll get you to test something. :)

Deal.

Thank you.

 

Offline Madrox

  • 27
  • Because destroying shivans ins´t enough...
    • My DeviantArt
Re: Problems with UI Text
I may have a solution for that. When you have your AMD card working and it's still unable to display text, PM me and I'll get you to test something. :)

Ok, i´ve fixed my GPU (although the performance continues to be an issue) and it seems i the problem with the text didn´t reappear, even with the amd gpu. But still, i´d like to have the fix you were proposing since i may need if i have problems in the future.

Thanks.

Also, if you will allow me a question: is the briefing room song from the Muv Luv series of visual novels? It sounded very similar.

 

Offline Axem

  • Administrator
  • 211
Re: Problems with UI Text
Oh sorry, I totally missed this post. Can you try the fix from this post? https://www.hard-light.net/forums/index.php?topic=95368.msg1879261#msg1879261

 

Offline redsniper

  • 211
  • Aim for the Top!
I also have an old ATI card and Axem's fix ^^ there works. It's a Radeon HD 6900 Series (I forget the exact model number) and worked fine with custom fonts in WiH, the previous WoD, and the JADs so.... it must be some newer change doing it. :confused:

E:

Did some troubleshooting with Axem. 3.8.0 Stable handles font rendering ok. It's something with the nightly builds.
« Last Edit: January 21, 2019, 07:50:43 pm by redsniper »
"Think about nice things not unhappy things.
The future makes happy, if you make it yourself.
No war; think about happy things."   -WouterSmitssm

HARD LIGHT PRODUCTIONS:
"...this conversation is pointlessly confrontational."

 

Offline redsniper

  • 211
  • Aim for the Top!
Nm, I caved and got a new vid card. It will forever be a mystery.
"Think about nice things not unhappy things.
The future makes happy, if you make it yourself.
No war; think about happy things."   -WouterSmitssm

HARD LIGHT PRODUCTIONS:
"...this conversation is pointlessly confrontational."