Author Topic: PCS2 User to User Help  (Read 85022 times)

0 Members and 1 Guest are viewing this topic.

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Wait, the texture has to be in the textures folder in PCS2 and data/maps?

...

Gosh darn it. That seems to have fixed the issue, thanks for the help.

No it doesn't.
You just need to tell PCS2 where to look for textures >.>
(´・ω・`)
=============================================================

 
Wait, the texture has to be in the textures folder in PCS2 and data/maps?

...

Gosh darn it. That seems to have fixed the issue, thanks for the help.

No it doesn't.
You just need to tell PCS2 where to look for textures >.>
The texture showed up normally when I viewed the model in PCS2, it was when I ran FS that the issue occured.

 

Offline Vasudan Admiral

  • Member
  • 211
    • Twisted Infinities
Haha, yeah it's a good idea to point PCS2 at the various mod folders and data/maps folders via the preferences so you don't need 2 copies of each map. Ie set up a texture path of "I:\Freespace2\data\maps\"  (Note that last slash is important!) or "I:\Freespace2\MyMod\data\maps\". If you want it to be able to read the maps from the mediavps and retail VPs, use "I:\Freespace2\" and "I:\Freespace2\mediavps\". (Obviously always replacing I:\ with wherever FS is on your system ;) )
Get the 2014 Media VPs and report any bugs you find in them to the FSU Mantis so that we may squish them. || Blender to POF model conversion guide
Twisted Infinities

 
Sigh, more bugs. I don't enjoy coming here to ask for help, so I'm not just pestering you guys every time I hit a minor roadblock, but I really don't see where the error is happening this time. I've got the handy-dandy .dae up in PCS2 just fine, but when I save it as a pof it says there was an error compiling the BSP data for one or more subobjects. Searching for info on BSP data only yields the infamous "inverted bounding box" error, but this one is strange. The resulting pof is my ship cut in half. Not a clean cut, though, it's jagged, conforming to the existing faces, as though a bunch of faces on one half of the ship just disappeared. I can find nothing strange or out of the ordinary about those faces, though.

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
Ouch. I've never had that happen.
Every time I got that error the ship came out ok (I just re-saved).

Do you still have the one before it was cut in half? Save it as a PMF, then restart PCS2 and save as POF, might help.
(´・ω・`)
=============================================================

 
I get a runtime error when I try to save it as that. It makes a pmf, but PCS2 crashes when I try to open it. I don't think it's related to the ship-cut-in-half error, though.

 

Offline Droid803

  • Trusted poster of legit stuff
  • 213
  • /人 ◕ ‿‿ ◕ 人\ Do you want to be a Magical Girl?
    • Skype
    • Steam
PCS2 hates your model.
You sure it has no geometry errors?
(´・ω・`)
=============================================================

 
None that I'm aware of.

 
Hmm, there's a function "Data -> Purge BSP cache", try using that before you save it (don't know if that will help though).
What version of PCS2 are you using? And could you upload the model, so we can try and reproduce the error?

 

Offline Zacam

  • Magnificent Bastard
  • Administrator
  • 211
  • I go Sledge-O-Matic on Spammers
    • Minecraft
    • Steam
    • Twitter
    • ModDB Feature
Haha, yeah it's a good idea to point PCS2 at the various mod folders and data/maps folders via the preferences so you don't need 2 copies of each map. Ie set up a texture path of "I:\Freespace2\data\maps\"  (Note that last slash is important!) or "I:\Freespace2\MyMod\data\maps\". If you want it to be able to read the maps from the mediavps and retail VPs, use "I:\Freespace2\" and "I:\Freespace2\mediavps\". (Obviously always replacing I:\ with wherever FS is on your system ;) )

And if you are testing within mod folders, setting ".\' and '..\.." works REALLY well as the top two entries.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!
Talk with the FSU on #SCP-FSU Talk with the SCP on #SCP
"If you can keep a level head in all this confusion, you just don't understand the situation"

¤[D+¬>

[08/01 16:53:11] <sigtau> EveningTea: I have decided that I am a 32-bit registerkin.  Pronouns are eax, ebx, ecx, edx.
[08/01 16:53:31] <EveningTea> dhauidahh
[08/01 16:53:32] <EveningTea> sak
[08/01 16:53:40] * EveningTea froths at the mouth
[08/01 16:53:40] <sigtau> i broke him, boys

 
Purging BSP data didn't help and I am using 2.1 alpha. I've attached the before and after models.

Edit: After exhaustively wrangling with PCS2 and Blender I have a better, if no less strange idea as to what is going on. For some ******-up reason there is a sort of region in blender that if any part of the model is poking inside it will hide, dormant, in the .dae and then when it is converted into a .pof it will eat away any face that was in that region. Simply moving it away from that region in blender is futile because when it is converted into a .pof it automatically centers the geometry and brings it partially into the region. I noticed it by rotating it in various ways and seeing the destroyed portion get moved around. Knowing this, though, does not help me solve the problem, because the region occupies 0,0,0 and a bit past it, so rotating it merely moves the region around parts of the ship.

W
T
F

[attachment deleted by ninja]
« Last Edit: February 12, 2011, 10:04:06 pm by Asteroth »

 
Hmm, if that's the case, the blendfile could be useful too. I am indeed getting the same error as you in PCS2.

 
So weird ...

[attachment deleted by ninja]

 
Okay, well, the two issues you have are unrelated. The "region in Blender" you were talking about is simply the view clipping plane; by default, it's set at 500 metres. which is too small for a ship of this size. So, go the 3D window, "View" menu, "View Properties", and under "View camera" pull "Clip end" up to the maximum of 10 000 metres. Centre your ship properly ("Center New" button in the  Mesh panel) and move it back to (0,0,0).

Then, you have quite some messy geometry in there, especially around the tailfins. This seems to be what's actually causing your conversion issue. Start off with W -> Remove Doubles (Editmode); then go to edge select mode and press Ctrl-Alt-Shift-M to select messy geometry. Specifically, there are faces inside the tailfins, which you should delete; and the tip of some of the tailfins doesn't line up properly. Select the two tip vertices and merge them.
After having done this, you should be able to convert the ship.

 
Remove Doubles

Removed 336 vertices

Gah! I thought I was alright at catching stuff like this, but I guess I'll need to pay better attention next time. I've fixed all the hiccups and got the model in-game without any significant issues. Thank you very much for your help, I never would have figured out the "clip end" thing on my own.

 
No problem, glad I could help :)

Every time I try to open the model attached, PCS2 crashes. I have the following error every time I open something, but only this model makes it actually crash, so I don't know if it's related.
The same thing occurs on the latest build.

Code: [Select]
14:14:14: file '', line 54: '=' expected.
14:14:14: file '', line 57: '=' expected.

[attachment deleted by ninja]

 

Offline Spicious

  • Master Chief John-158
  • 210
Try a newer build.

 
Ah yes, that works. Thanks :)

 
Re: PCS2 User to User Help
Hi, longtime lurker here.  I tried to get started with putting some ship models into FreeSpace yesterday, but PCS2 was crashing every time with

Code: [Select]
Runtime error! 
Program: C:\Program Files (x86)\POFCS2\pcs2.exe
R6025
- pure virtual function call

I tried for a couple of hours to see if something was up with my mesh, but to no avail.  I use Blender and the DAE exporter. 

Finally, just for a test, I opened up the vanilla FS2 medusa in sparky_fs2.vp with PCS2, exported it to DAE, and tried to reimport with "Import Geometry".  No luck, I got the same crash. 

Anyone have an idea what is up?  I'm running on Windows 7 64 bit, and I have the VS 2008 SP1 x86 runtime installed, along with the DAE files from http://the158th.hard-light.net/spicious/libcollada14dom21.7z
« Last Edit: March 03, 2011, 05:24:14 pm by BlasterNT »

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: PCS2 User to User Help
Do you have the latest PCS2.1 from Spicious's sig (couple posts up)?  What video card?  Double check your geometry for stacked polys/verticies. 
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras