Author Topic: Joystick not working in-game  (Read 451 times)

0 Members and 1 Guest are viewing this topic.

Joystick not working in-game
I just did a clean reinstall of Freespace 2 and the open stuff, and the game controller is not working in game. I've gone through other support discussions and tried their suggestions. It worked before the install; I did an install after using Knossos to install ASW, I could only play ASW. I uninstalled Knossos and went for a clean reinstall of everything.

Here's what I've done:
I made sure my controller is set as default for older games.
I selected the controlled from the menu in the wxlauncher
I tried a regedit fix, adding in current joystick, and playing with different values.

Does anyone know what's going on here?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Joystick not working in-game
Which version of wxLauncher and FSO are you using? If you're using the latest wxLauncher, it should work fine with Knossos. The problem that FSO ignored your wxLauncher settings is usually a result of using an outdated version.

Did the joystick work with Knossos?

 
Re: Joystick not working in-game
I actually just figured this out; the joystick worked with Knossos. The problem is, I forgot to delete the %appdata%/HardLightProductions folder after uninstalling Knossos (as per their instructions; I should read those better....); once I did so, the problem was resolved.