Author Topic: Resolution Issue, Help!  (Read 170 times)

0 Members and 1 Guest are viewing this topic.

Resolution Issue, Help!
Hello! I recently did a fresh installation of Free Space Open using the Knossos 0.13.3 Installer. I am having trouble getting FSO to run in anything beyond it's native resolution despite my settings in Knossos set to indicate other wise. I have set both Knossos and the FSO executables to run in admin mode, as well as set them to "Override high DPI scaling behavior, scaling performed by application." I have my custom flags for my FSO entry set to "-res 1600x900" and I have tried several combinations of other flag settings, such as fullscreen windowed (which simply put a window the size of the game's default res in the middle of my desktop) and "stretch interface to fill screen" (which does nothing whatsoever.) No part of the game is in 16:9 resolution. The SCP splash screen, the opening cinematic, the menu hanger, the loading screen, as well as the in-game render are all in 4:3 pillarboxed low-res. I have my graphics modes in Knossos set to 1600x900 32bits trilinear. I am running Windows 10 on a 64bit processor with a GeForce GTX 660. My CPU is a Intel Core 2 Quad 8300. i have 8gigs of ram. I do not have Windows set to use any sort of custom dpi scaling.

I have checked out several other threads on these forums
https://www.hard-light.net/forums/index.php?topic=95171.0
https://www.hard-light.net/forums/index.php?topic=95207.0

But I haven't found any sort of solution that works for me.

Here is my log:
https://fsnebula.org/log/5bf679bfcb0d33337ba851ff

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Resolution Issue, Help!
I think part of your issue might be related to this:

Code: [Select]
Searching root pack 'E:\Steam\SteamApps\common\Freespace 2\Knossos\A FOLDER I ****ING GUESS\FS2\sparky_hi_fs2.vp' ... Failed to read file entry (currently in directory )!
0 files

I think sparky_hi_fs2.vp is what tells FSO to use "hi-res" graphics, i.e. above 800x600 and it seems to be corrupted in your install. Maybe you could try re-installing the original Freespace2 via Steam, then copy the file (which I presume is in this dir: 'E:\Steam\SteamApps\common\Freespace 2') to the location above? I'm not sure how to trigger knossos to recopy the file otherwise I'd suggest trying that as well.

Also. Awesome knossos data dir name  :lol:  It _may_ also help to select a knossos data into it's own directory outside the Steam install dir. e.g. E:\fso That might require you to re-download everything, so perhaps don't worry about it unless someone else can provide better instructions on how to move the files around.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: Resolution Issue, Help!
So I reinstalled both Freespace 2 through Steam, and Knossos (to a different directory) and it seems to finally be working! It was really a no-brainer but i guess i was so focused on trying all the crazy complicated solutions that the most simple didn't even occur to me. Knossos keeps throwing errors during the download of mods/ MVPs though, and i keep having to verify mods. certainly not the most stable platform i've worked with regarding mod management.

Thank you for your help!

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Resolution Issue, Help!
Can you please post your %AppData%\knossos\log.txt (after installing a mod)? I'm wondering why Knossos seems to be having problems during that.

 
Re: Resolution Issue, Help!
Sorry, just saw this. I managed to get all of my mods (which is basically just the MEDIAVPS for FS2 and the FS1 port, and the FS1 MVPs.) Here's the log, but i don't know how useful it will be now that everything.... MOSTLY works/

I'm afraid i'm having a new problem: the FS1 Port  (sorry if this is the wrong place for this) is not playing the appropriate intro video, even when selected through the cutscenes menu. it plays the FS2 one.

EDIT: OH and to give a bit more information regarding the nature of the errors: while downloading mods it would frequently say something about having a catastrophic error, adn that i may need to verify files. This persisted for a while and sure enough, when i went to verify the files. they were in need of replacement. I changed the download directory, and everything SEEMS to be going fine regarding that.. for now. but i'm still having trouble with that one last problem about the opening cutscene.
« Last Edit: November 24, 2018, 12:18:16 am by DevonJWing »

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Resolution Issue, Help!
The critical error you saw is caused by a bug in the routine that creates the error message. Sadly this means that we don't know what actually went wrong until we can get a log after you see that message. FWIW the log doesn't contain any important errors... it just seems like a few mods were installed multiple times? That might cause a bunch of problems but I'm not entirely sure about that. This was most likely caused by you changing the download directory. Which directory is it set to now? Can you give a list of folders and files withing that directory (a screenshot might be the easiest way)?

 
Re: Resolution Issue, Help!
Here ya go.  Any thoughts on the intro movie not being correct?

EDIT: Also, and I swear this game is giving me every possible issue it can to piss me off at this point, but I have no voices in the briefing menus or in combat. there is the very occasional shout regarding enemies warping in, but beyond that, all characters and briefings are completely silent. Anyone have any ideas?

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: Resolution Issue, Help!
Using the data folder in Knossos' own directory is NIT what I expected but I suppose it won't cause any problems...

What's inside the FS2\fsport-1.0.0 and FS2\fsport-mediavps-3.7.2 directories?

The missing voices and intro movie are probably caused by missing mod files.