Author Topic: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)  (Read 114262 times)

0 Members and 3 Guests are viewing this topic.

Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Hello,

Just bought Freespace 2 to play for the first time and wanted to try out the graphical improvements. I'm trying to use this Knossos installer but at the point during the setup where it's asking where my Freespace 2 retail game is installed I'm getting the following error message when I confirm its location:
"A critical error occurred! Knossos might not work correctly until you restart it. The error has been reported and will hopefully be fixed soon."

Knossos can see where it is but it's not working. When I restart Knossos and try to install any of the mods a separate box headed "Retail data missing" appears. Again it can see the folder but it doesn't want to install it. If I try to select any of the .exe files it brings up the same error message "A critical error occurred! Knossos might not work correctly until you restart it. The error has been reported and will hopefully be fixed soon."

Any ideas? When I initially installed Knossos my Norton anti-virus got jittery about it but I instructed it to leave well alone. I'm using the Gog version of the game and I'm on Windows 10 if that helps.


 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Where is your GOG FreeSpace installed to?  Wondering if it's permissions?  Eh, someone who knows more will be along shortly, don't worry.  ;)

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
IIRC ngld said there's a bug in the 0.13.x versions that'll be fixed soon. In the meantime you can try installing 0.12.4, install FS2 retail, then upgrade to 0.13.x.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
IIRC ngld said there's a bug in the 0.13.x versions that'll be fixed soon. In the meantime you can try installing 0.12.4, install FS2 retail, then upgrade to 0.13.x.

Thanks! Using the earlier version seemed to have worked!

 

Offline ksotar

  • 26
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
IIRC ngld said there's a bug in the 0.13.x versions that'll be fixed soon. In the meantime you can try installing 0.12.4, install FS2 retail, then upgrade to 0.13.x.

Where to get old one?

UPD here https://github.com/ngld/knossos/releases

 

Offline oljo

  • 23
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Hello, i get this error on xubuntu 18.04.1 when i launch knossos "I don't know how to handle "override_dh_link" i only know fso://

What to do?

  
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Tearing my thinning hair out here.

Cannot get any mods working. Please look at attached image for sequence of events.

GTX1060 6Gb + 16Gb RAM. Windows 10 Home. Intel 7700HQ

Any ideas what this is or I'm doing wrong? Please help.

[attachment stolen by Russian hackers]

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Hello, i get this error on xubuntu 18.04.1 when i launch knossos "I don't know how to handle "override_dh_link" i only know fso://

What to do?

You can modify /usr/bin/knossos & remove "override_dh_link" from the file and (for me at least) it'll work as expected.

Or if you don't want to modify the file, just run this from a terminal:
Code: [Select]
python3 /usr/share/knossos/knossos/__main__.py
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Tearing my thinning hair out here.

Cannot get any mods working. Please look at attached image for sequence of events.

GTX1060 6Gb + 16Gb RAM. Windows 10 Home. Intel 7700HQ

Any ideas what this is or I'm doing wrong? Please help.

Assuming this is occurring on the latest version (0.13.2) then try this:

IIRC ngld said there's a bug in the 0.13.x versions that'll be fixed soon. In the meantime you can try installing 0.12.4, install FS2 retail, then upgrade to 0.13.x.

You could also see if Diaspora will install & run ok as it doesn't require the FS2 retail install.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Knossos 0.13.3 has been released, it fixes both the critical error message when trying to install retail data as well as the override_dh_link issue on Ubuntu (and derivates).

Sorry about the delay.

 

Offline oljo

  • 23
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
Hello, i get this error on xubuntu 18.04.1 when i launch knossos "I don't know how to handle "override_dh_link" i only know fso://

What to do?

You can modify /usr/bin/knossos & remove "override_dh_link" from the file and (for me at least) it'll work as expected.

Or if you don't want to modify the file, just run this from a terminal:
Code: [Select]
python3 /usr/share/knossos/knossos/__main__.py


Thanks! will try it

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Firstly a big thankyou for your help, and wow the game I loved 20 years ago lives again....buuut

I changed my HUD colour and got this (attached) how do I fix this as the game now won't run (who'd have thought changing HUD colour would have triggered this).

Hitting debug would step me through the game up to the command briefing, but then it would pause at the game itself and then not run (all the while putting that error box up and stepping through each scene change).

I will say though bugs n all this is incredible work (cockpit mod would be nice but in reading I don't think there are any reliable mods for this).

[attachment stolen by Russian hackers]
« Last Edit: October 18, 2018, 01:03:20 pm by nevar777 »

 

Online wookieejedi

  • 28
  • Intensify Forward Firepower
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Firstly a big thankyou for your help, and wow the game I loved 20 years ago lives again....buuut

I changed my HUD colour and got this (attached) how do I fix this as the game now won't run (who'd have thought changing HUD colour would have triggered this).

Hitting debug would step me through the game up to the command briefing, but then it would pause at the game itself and then not run (all the while putting that error box up and stepping through each scene change).

I will say though bugs n all this is incredible work (cockpit mod would be nice but in reading I don't think there are any reliable mods for this).

Were you using a mod or playing regular Freespace 2? Also, what FSO build are you using?

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Ok so the versions I'm running are as follows:

knossos 12.4 (because my first attempt at this was with 13.2 and it gave me the finger)
base FSO 3.8.0-3
Freespace port 1.0.0
FS Port MediaVPs 3.7.2

Also Freespace 2 (basic FSO update) crashed with the same error.
« Last Edit: October 18, 2018, 04:37:43 pm by nevar777 »

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Knossos 0.13.3 fixed the bug you encountered in 0.13.2 so it's safe to update to that. It most likely won't resolve this specific issue, though.
Can you try and go to Knossos' settings, select Nightly as the preferred stability in the Knossos section, save, update FSO and launch the mod again? It will most likely crash with the same error but I'm hoping the conversion to JSON will work regardless. If it worked, you'll find a file under %AppData%\HardLightProductions\FreeSpaceOpen\data\players\<PILOTNAME>.json. Please attach that file to your post (if it exists).

If that didn't work and you still can't launch FSO, you could try cloning your pilot but aside from that IIRC the only solution is deleting your pilot.

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
 :banghead:
I have problems with knossos launcher. I run it under ubuntu, and it went jus fine until just a few days. Awesome program to play freespace, I even downloaded some mods and they were just great!!

The problem is that now I cant get knossos to start, it only give me this warning: "I don't know how to handle "\override_dh_link"! I only know fso:// .", click "OK" and then nothing. This message shows from the very first day, but the program ran anyways so i didnt even bother. Now it doesn't i was left in the middle of the tango campaign!

Please help me solve this issue.
« Last Edit: October 19, 2018, 05:48:45 pm by [email protected] »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
You can modify /usr/bin/knossos & remove "override_dh_link" from the file and (for me at least) it'll work as expected.

Or if you don't want to modify the file, just run this from a terminal:
Code: [Select]
python3 /usr/share/knossos/knossos/__main__.py
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Knossos 13.3 works great and thanks again for your amazing support.

Question: where are the pilot profiles stored as I did a full uninstall to kill the issue BUT the pilot data remained...are they stroed in the windows user profile?

Again thanks to you all for your outstanding help.

A personal view point having played this 20 years ago when it first came out. I remember a game that was similar to wing commander but there was one huge difference that hit you immediatly: flight model.

Wing Commander dog fights were basically a ship moving diagonally across your screen from corner to corner - fast and annoying.
Freespace came and dog fights were memorable glide like an eagle affairs, like the best elements of a star wars dog fight.

Graphically at the time I was running a voodoo 1 at 640x480 and the graphics were amazing.

Move forwards 20years (yes sadly it was that long ago and I was 21) and time had not been kind to the original which now somehow looked like everything had been rendered to look like a half dissolved alchazeltser (buggered if I know how to spell it but you get the idea).

Now because of the efforts of all of you over the last 18 years my old gaming friend has come home.

I've missed this game of a simpler time.

Thankyou all.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)
Knossos 13.3 works great and thanks again for your amazing support.
Great, hope you're having fun with the game!

Question: where are the pilot profiles stored as I did a full uninstall to kill the issue BUT the pilot data remained...are they stroed in the windows user profile?
%AppData%\HardLightProductions\FreeSpaceOpen\data\players

I've missed this game of a simpler time.

Thankyou all.
You're welcome.  :)

 
Re: PUBLIC BETA: Knossos 0.13.2 (combined launcher/installer)
You can modify /usr/bin/knossos & remove "override_dh_link" from the file and (for me at least) it'll work as expected.

Or if you don't want to modify the file, just run this from a terminal:
Code: [Select]
python3 /usr/share/knossos/knossos/__main__.py

You are a genius, thanks   ;) :yes:. Now knossos starts with no problem, and without the annoying  warning too!