Author Topic: PUBLIC BETA: Knossos 0.10.1 (combined launcher/installer)  (Read 15220 times)

0 Members and 1 Guest are viewing this topic.

Offline Rae2005

  • 22
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Let's get back to the original problem...

@Rae2005: That error in general means that a 64bit application is trying to load a 32bit DLL (or the other way round). In this case your 64bit FSO is probably trying to load the 32bit OpenAL DLL packaged with Knossos. If you install OpenAL from Creative or put OpenAL Soft's DLL in the FSO directory, your problem should be solved. The latest nightlies and the next FSO release will include the OpenAL DLL as well so this should more or less fix itself in the future. I could add a warning if the OpenAL DLL is missing though...
Thank you that has appeared to fix the problem. funny detail though is sometimes it worked and sometimes it didn't

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Thank you that has appeared to fix the problem. funny detail though is sometimes it worked and sometimes it didn't

Ah, Windows...

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Greetings,

Firstly I’d like to commend you guys for this tool. I’ve tried it and despite some of the new aspects of the Knossos (extra folder outside of the main FS2, mods being installed at the new Knossos folder instead of the FS2, layout...) I’ve sticked with it. I understand the intent of what is being done with Knossos. I’ve used mainly the YAL launcher with the mods being installed at the main FS2 folder. I’m running on a Windows 7 SP1, on a i5 with 2.4 GHZ. But (oh man here it comes) today I’ve installed the 0.8.1 update via the Knossos. When I tried to run it I received an error message, saying that it couldn’t find the game executable. So I go and do a full review on the options selected, because with was working fine until the update. On the next instance I’ve received a message saying that I had to reboot the Knossos, which I did and rebooted my pc as well. However the error messages kept on going the same and couldn’t run FS2 or any of the mods already installed. Furthermore, I tried to run FS2 again from the YAL launcher and now the game loaded the original retail version only, none of the mods installed in the main FS2 folder run anymore, not even the MediaSVPs_2014 mod. It must be something I’ve done wrong, or at least I tend to normally think that way immediatly. But I feel at a loss since everything I’ve done doesn’t work (reselecting the build, the exe in the options, etc...). Could you possibly point me out on a solution please? This is the game that I play the most...

PS - Sorry for the loooong description, just trying to provide as much info as possible.

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️🅰➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Well, I can say that, Knossos _should_ not modify an existing FS2 install whatsoever.  It only asks for its location so it can copy the retail data into its own storage location.  It'd be like if Steam could have copied the pak files for Half-Life 1 instead of having to download them, except since they could verify license keys they didn't need to bother with copying data.  But you still had to install a Steam-ified Half-Life even if you already had the old 1.1.0.0 install laying around with your Counter-Strike and whatever mods, and other less popular mods did all have to go through the pains of being modified to work with Steam installs, etc.  It's really no different here, trying to move to a new paradigm can be a temporary pain but in the long run I think everyone can agree that a unified distribution and launching system is easier to work with these days, even if it does have to replace an existing setup to move forward.

But, if you never modified your own old install, Knossos should not have either, and I don't know why it would no longer work.  The item shared between the two would be your user data folder.  You could look into Users\<yourname>\AppData\Roaming\HardLightProductions\FreeSpace2Open\ folder but I'm not sure what I would recommend to check.  As a test, you could try simply renaming that folder and seeing if your YAL version creates a new one and runs successfully.  Don't delete it as it has your pilots, etc, but if that fixes anything then it can narrow down where the problem might lie.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline m!m

  • 210
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Knossos didn't change anything about your existing install but it changed where the engine expects the configuration data (which is also what chief1983 mentioned). YAL is pretty outdated and hasn't been updated to handle the new way FSO stores its configuration (and I am a bit proud that it still worked :p) so if you want to continue using both your Knossos install and the old install you will need to use wxLauncher. That has full support for the new configuration system.

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Thank you so much for the quick reply guys! I didn’t do anything and the Knossos launcher is now working!  :confused: I think I’m going to stick with the Knossos Launcher anyhow, I’ve tried the wx launcher (also on a separate folder from the main FS2 game folder) and it was easy to configure. Despite this I tried to load with the Media SVP’s 2014 mod and it didn’t loaded the hi-res textures again (pressing F3 at the main menu and checking the ship models, they show the old 1999 textures)... Ran through the configurations (HUD, Graphics, Gameplay, Audio, etc) and set the ones I’ve been using for the last 10 months without change, those that worked fine before installing Knossos. And still no cigar...  :hammer: Funny thing is that I’ve only noticed now that my old pilots are ALL gone!  :banghead: I was playing the SG 2017 mod (from the YAL launcher) and I was in the 20th mission or so, now it is gone! Now only the new pilots created from the Knossos launcher are displayed, even if I go back to launch FS2 with the wxlauncher or yal. Well, at least it was the only mod I was playing now, I had just finished the Exile mod!  :lol: Gonna start all over again...  :nono: I’m gonna give up on the “old” launchers and stick with the Knossos, I’m getting the hang of it now (I think...). Once again, thank you for the fast reply guys!  :D
« Last Edit: February 15, 2018, 02:15:28 pm by Viriatus79 »

 

Offline Cyborg17

  • 29
  • A-1 Supar
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
I installed around ten mods successfully and then whenever I run knossos my computer crashes in a "kernel panic".

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
how do you know what change in the updates? of the mods?

 

Online Novachen

  • 28
  • The one and only Capella supernova.
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
No, so far there is any changelog.

But i did some changes and reuploads yesterday:
A Walk in the Sun 1.0 -> 1.0-A
This was only a repackaging from one Complete download to several individual downloadable VPs, because that would make updates much easier, because in following versions only the VP file have to be redownloaded that was changed. So you do not have to redownload the whole mod.

Dimensional Eclipse 1.1-b -> 1.1-B
The same change. All VPs are own packages now.

Dusk Wars Act 1 2.0 -> 2.0-A
Mostly the same change, but also some smaller Table fixes for DWA1.

Dusk Wars Act 2 1.0 -> 1.0-A
Repackaging mostly, but some of the tbms are smaller, because some of the DWA2 fixes were moved into the DWA1 files.

Friends and Foes: Retribution 1.1 -> 1.1-A
Repackaging only

Into the Halls of Valhalla 1.3.1-Nova -> 1.3.2-Nova
Repackaging. I also made some additional mission and table fixes.

Luyten Civil War 1.1-Nova -> 1.1.1-Nova
Repackaging. I created a LCW-specific flashes configuration for its ships and weapons.

Renegade Resurgence 1.1 -> 1.1.1
Repackaging. But you can also find some smaller mission fixes in this version.

Rogues! 1.0 -> 1.0.1
Repackaging. I also added some debriefing stages in a few missions

Shadow Genesis 2.1.2017 -> 2.1.2017-A
Repackaging only

VeniceMirror 1.4-Nova -> 1.4.1-Nova
Repackaging. I also include one additional bugfix for one mission aswell i created a complete flashes configuration for all VM ships and weapons
« Last Edit: March 02, 2018, 03:23:14 am by Novachen »
Female FS2 pilot since 1999.

German Translations created by me:
Between the Ashes: Slaves of Chaos, FreeSpace Port, The Destiny of Peace, Silent Threat: Reborn, Awakenings (in development)

Upgrades and Bugfixes:
FSPort Mission Upgrade, Luyten Civil War, Into the Halls of Valhalla, VeniceMirror

Other projects:
Out of the Shadow: Nova Safiya Edition (Remake of the Out of the Shadow campaign, in development)



If you want to know, what my nickname means, -chen is a german diminutive term, so you can translate Novachen as something like Little Nova or Novalet.
Even my original meaning of this name is more like "Sweet pretty deadly (Super)Nova" ;).

 

Offline ngld

  • 29
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
I installed around ten mods successfully and then whenever I run knossos my computer crashes in a "kernel panic".
... That shouldn't be related to Knossos itself. Can your run Chromium or other applications that use OpenGL? What's the callstack for the kernel panic?

how do you know what change in the updates? of the mods?
Unless the mod author puts a changelog in the mod's description, there isn't a way, yet. I'm planning to implement changelogs eventually.

 

Offline Cyborg17

  • 29
  • A-1 Supar
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
... That shouldn't be related to Knossos itself. Can your run Chromium or other applications that use OpenGL? What's the callstack for the kernel panic?

It wouldn't stop happening even when I wasn't running Knossos, so I uninstalled everything and now everything is fine.  This computer is pretty ancient, so I'm chalking it up to that.

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Just Downloaded this software and trying to run the program through my files in my x86 folder. Knossos will download mods but when I try to run the program it comes up with an error message. Help! Return code 3221225595. No idea what this means

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Could you post a screenshot of the error?
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
I'll see what I can do.


edit** I've tried taking a screenshot but my print screen button isn't working for some reason. it says

fs2_open_3_8_0x64_AVX.exe - Application error


The application was unable to start correctly (0x000007b). click ok to close the application.
« Last Edit: March 08, 2018, 03:32:38 pm by Zehlayer »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
What sort of CPU does your computer have? And what which anti-virus program are you running, Freespace Open can be affected by some anti-virus applications.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline ngld

  • 29
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
0x000007b means that a 64bit program is loading a 32bit DLL or the other way round. The problem here is probably the OpenAL32.dll.

You can either install a recent nightly by switching to Knossos' settings, selecting "Nightly" as your preferred stability and updating your FSO installation (go to Home and click UPDATE on the FSO tile).

Or you can fix it by copying the missing DLL into FSO's folder: Download this archive and copy the openal-soft-1.18.2-bin\bin\Win64\soft_oal.dll into your FS folder\bin\FSO-3.8.0-2\x64\OpenAL32.dll.

 
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
OK.....not sure what I am doing wrong. I bought the game through steam and yet Freespace open installer can't detect my retail version of the game. I am at a loss as when I do the GOG setup I can't find the files even though when I search my computer I can find my Freespace 2 game in the directory on my hard disk....

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
There seems to be a bit of confusion in your post - and hence in me :)

GoG FS2 Retail vs Steam FS2 Retail? (neither will search for retail files because they're installing the retail files?)
FreespaceOpen Installer vs Knossos? (I can't recall what retail file search the FreespaceOpen installer runs, but Knossos should search & find the install, if it's in the default/standard location - I think)

In theory you just need to:
Install FS2 retail via Steam
Install Knossos & install at least the FSO mod (you probably want MediaVPs 3.7.2 as well)
Fix the 0x000007b by following the instructions in ngld's post.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

  
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
OK. Progress has been made. I  can now get the program to operate but when FS2 loads there is no audio and nothing is clickable via mouse and keyboard... Can't engage in missions either...


edit*** Updated SCP on knossoss. Got audio audio and system working but my screen is zoomed WAY far in on the screen and I can't see what I am doing.

Edit #2 .......I GOT IT TO WORK!!!! Thanks guys for all your help. Greatly appreciated and the game look phenomenal!
« Last Edit: March 10, 2018, 02:58:33 am by Zehlayer »

 

Online Novachen

  • 28
  • The one and only Capella supernova.
Re: PUBLIC BETA: Knossos 0.8.1 (combined launcher/installer)
Well i have a developer question.

Some mods have their VP files directly in the root folder and do not have folders with the content of the respective package.
Actually i am curious how i can create that? Because i always got an error message if i try to change the folder for the respective files in the mod.json.

So i have to place all VPs in individual folders so that they are individually selectable.


Also i am missing a function to download and so to test the own uploads. I already encountered some problems with own mods that were unable to extract due to write-protected VPs or simply by upload errors (interrupting a upload to restart it later is a very bad idea). But i encountered these problems only by the installation on a second system. But there should be another possibilities to test your mods for that kind of errors.
Female FS2 pilot since 1999.

German Translations created by me:
Between the Ashes: Slaves of Chaos, FreeSpace Port, The Destiny of Peace, Silent Threat: Reborn, Awakenings (in development)

Upgrades and Bugfixes:
FSPort Mission Upgrade, Luyten Civil War, Into the Halls of Valhalla, VeniceMirror

Other projects:
Out of the Shadow: Nova Safiya Edition (Remake of the Out of the Shadow campaign, in development)



If you want to know, what my nickname means, -chen is a german diminutive term, so you can translate Novachen as something like Little Nova or Novalet.
Even my original meaning of this name is more like "Sweet pretty deadly (Super)Nova" ;).