Author Topic: PUBLIC BETA: Knossos 0.13.3 (combined launcher/installer)  (Read 38953 times)

0 Members and 1 Guest are viewing this topic.

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
I also add you what my FSO folder look like (maybe there is something missing or something that should not be here). I noticed (but maybe it's normal) that there were common dll files beteween Knossos folder and FSO folder.

(And sorry for the lot of attachments, it's to make things cleared, and share common view)

Thanks  :)

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
Looks fine to me at a glance... Can you please generate a debug log and test what happens if you rename the opengl32.dll in FSO's directory (just choose a different name like disabled_opengl32.dll)? I know that it's part of ReShade but I want to see if it's part of the problem.

 
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
@Bobun: Check if shadows are enabled or not.  For me that was the problem. 3.8.1 automatically enabled shadows while 3.7.2 didn't.

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
I'm trying to be methodical to understand the origin of the problem. So here what i did, following your instructions:

Deleted both FSO-3.8.0-3 and FSO-3.8.1-20180908 folders
Uninstalled Knossos 0.12.3 (remember I can’t open it, so to be able to do the debug log I must use the only version that works for me which is Knossos 0.8.3)
Installed Knossos 0.8.3
Downloaded and installed a new FSO-3.8.0-3 and FSO-3.8.1-20180911

Note: as I don’t have any opengl error message when I use Knossos 0.8.3, I did not copy D3DCompiler_47.dll, libEGL.dll and libGLESv2.dll from Mali OpenGL ES Emulator 3.0.2.g694a9 folder to Knossos folder. This opengl error message is specific to Knossos 0.12.3

NOR did I apply ReShade_Setup_3.4.1 to FSO build at the start of my tests (check bellow). But applied ReShade at the end (check log3_fs2_open.log). Like that you have elements to compare.

Tests:
•   Essay 1-Knossos 0.8.3: Tried to use FSO builds without applying Reshade:
   Knossos Settings\Prefered Engine: Nightlies

FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.8.1
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash –enable_shadows
Result: negative (can’t see ships/vessels in techroom)
I generated the fs2_open.log (Check Log1_fs2_open.log)

@ DeadNova: I checked the FSO Settings in MediaVPS 3.8.1 Options button and yes “Enable Shadows” was “On”, so I deselected it.
Result: negative (can’t see ships/vessels in techroom)

I though that maybe it was something I selected in the list type (FSO settings) that be the problem, so I selected only these flags to check potential incidences: –dualscanlines –targetinfo –rearm_timer -3dwarp –warp_flash –ship_choice_3d –weapon_choice_3d -3dshockwave –orbradar
Result: negative

In addition, I wanted to check if “Enable shadows” had really an incidence on my issue. Here results:
FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.8.1
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: negative

FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.8.1
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash –enable_shadows
Result: negative
 
FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.7.2
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash -enable_shadows
Result: negative

FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.7.2
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: negative

   Knossos Settings\Prefered Engine: Stable
FSO build: FSO 3.8.0-3 with MediaVPS 3.8.1
Flags: -missile_lighting -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: Error message (seems a “normal” error message as MediaVPs 3.8.1 works only with nightlies)

FSO build: FSO 3.8.0-3 with MediaVPS 3.7.2
Flags: -missile_lighting -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: Positive (can see ships and vessels in Tech room)

FSO build: FSO 3.8.0-3 with MediaVPS 3.7.2
Flags: -missile_lighting -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash –enable_shadows
Result: Positive

Conclusion: @ DeadNova and everyone, “Enable shadows” seems to have nothing to do with the issue for me.


•   Essay 2-Knossos 0.8.3: Tried to use FSO-3.8.1-20180911 (with Reshade) with MediaVPS 3.8.1

Applied ReShade_Setup_3.4.1 to FSO-3.8.1-20180911 (fs2_open_3_8_1_20180911_138a1d0_x64_SSE2.exe) folder
Did not rename opengl32.dll

   Knossos Settings\Prefered Engine: Nightlies
FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.8.1
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: Negative
I generated the fs2_open.log (Check Log 2_fs2_open.log)

Renamed the opengl32.dll from FSO-3.8.1-20180911 to “disabled_opengl32.dll”
FSO build: FSO 3.8.1 -20180911 with MediaVPS 3.8.1
Flags: -3dshockwave –dualscanlines –targetinfo –orbradar –ship_choice_3d –weapon_choice3d -3dwarp –warp_flash
Result: Negative
I generated the fs2_open.log (Check Log 3_fs2_open.log)

Cheers

 
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
Can you go to your Home tab, click the details button for FSO and tell me which version you have installed? Should be in the top left corner. Also, please click on Options > Verify file integrity and tell me what the result was. Did you modify (or delete) any of FSO's DLLs?

The version is 3.8.1-20180911 and the popup message state that no problems were detected when verifying file integrity.  I haven't modified or deleted any of the DLLs.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
@Bobun: Thanks for detailed information! I think we can safely assume at this point that ReShade isn't causing any of the current issues. The log confirms that your driver is working and that it supports OpenGL 4.5. I've compared the two Knossos releases and the only significant difference that could cause the problem is a packaging issue in 0.8.3 which caused Qt to be unable to use Windows' "Vista style". It's weird. I really doubt that this causing your problem. Hm... I'll see if I can come up with any potential solutions.

@Konatsat: As an explanation: That error message is coming from windows and means that a 32bit exe file is trying to load a 64bit DLL (or the other way around). The annoying part is that Windows doesn't tell you which DLL is causing the problem so you have to guess. Does the error occur with older nightlies (try one from last year for example) or on 3.8.0?

 

Offline Vidmaster

  • 211
  • Inventor of FS2 bullettime ;-)
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
I have tried out Knossos for the first time today and came away impressed. I could see myself switching over to a pure Knossos-setup in the future, if there is a ZIP or EXE-only distribution.
Devoted member of the Official Karajorma Fan Club (Founded and Led by Mobius).

Does crazy Software Engineering for a living, until he finally musters the courage to start building games for real. Might never happen.

  

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Anims: 420, Cutscenes: 10, Mainhalls: 7, Logos: 52
    • Steam
    • Twitter
    • Mix-Hai Productions
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
I know there's an issue on github to make portable Knossos an option. I don't think ngld has had time to prioritize that yet.
Cutscene Upgrade Project - Mainhall Remakes - MixaelANITools - Between the Ashes - MjnMixael's Render Boutique - Mix-Hai Productions
Youtube Channel - P3D Model Box - Photobucket Albums - Model Releases - Downloads
Between the Ashes is looking for committed testers, PM me for details.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!

 

Offline TrashMan

  • T-tower Avenger. srsly.
  • 213
  • God-Emperor of your kind!
    • Minecraft
    • FLAMES OF WAR
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
So, someone tell me about creating mods funcion?
It has a section for mod.ini files, but throws a fit when I point to it.
Does this create a mod folder, can I copy old mod folder? How's this work?
Nobody dies as a virgin - the life ****s us all!

You're a wrongularity from which no right can escape!

 

Offline niffiwan

  • 211
  • Eluder Class
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
Try this guide, if that doesn't answer your questions we'll work out how to improve the guide:
https://docs.google.com/document/d/1oHq1YRc1eXbCgW-NqqKo1-6N_myfZzoBdwZuP16XImA/edit?usp=sharing

(or just ask either here or in Discord #knossos)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
Quote
@Bobun: Thanks for detailed information! I think we can safely assume at this point that ReShade isn't causing any of the current issues. The log confirms that your driver is working and that it supports OpenGL 4.5. I've compared the two Knossos releases and the only significant difference that could cause the problem is a packaging issue in 0.8.3 which caused Qt to be unable to use Windows' "Vista style". It's weird. I really doubt that this causing your problem. Hm... I'll see if I can come up with any potential solutions.

Hi guys and NGLD, i was waiting for your return and potential solution for the 2 problems i posted in my posts before, but as i didn't have any answer yet, i did other tests this weekend and finally solved one of my issue. I want to share with you guys what i did as a "return of experience" so that you will be able to enhance Knossos. I've noticed bugs with fs2_open_3_8_0_x64_AVX, fs2_open_3_8_0_x64_SSE2 and with Knossos.

It was so frustrated to not be able to play with the new Mediavps that i decided to check why it didn't work. So i I did a complete uninstallation (without forgetting files like "knossos" in  Appdata\local and roaming plus "fsoinstaller.properties" in User\Name) of everything (mods, FSO, knossos, game,...) in order to eliminate side causes and to focus only on root causes.

Then i installed everything back (game+FSO+Mediavps 3.8.0 & 3.8.1) from Knossos 0.8.3
I launched the game from Mediavps 3.8.1 using FSO 3.8.0-3 (which was fs2_open_3_8_0_x64_AVX). I tried also the last nightlies Results: both the same i cannot see any ships in the techroom.

After this, i thought that "okay, accept that you will probably never play with the new Mediavps, so let's play a mod that don't need those!"

So i installed the last version of Blue Planet mod.
I launched the game using FSO 3.8.0-3 (which was fs2_open_3_8_0_x64_AVX).
Results: intro video play as normal but 1st ingame video play very slow like 1 image per second and same during mission. :eek2:
It was very odd since i haven't had this problem before. I was always be able to play this mod in the past without any problems at all.

 :mad: From here i was very angry not understanding where the problem could be from (and don't tell me it's my computer, cause it's not! been checked in posts before).

I tried one last thing: installing the new MediaVP from the old way with openinstaller.jar
So i did a clean uninstallation of everything, then i installed the game and used last version of openinstaller.jar. Installed wxlancher, FSO and only MediaVPS 3.8.1.
Opened wxLauncher, chose Fs2 open 3.8.0 SSe2 64bit
Played the game and got an error message (check image) "the application failed to start correctly (0xc000007b)"
Ok so it seems that there is something fishy with fs2_open_3_8_0_x64_SSE2 as both old platform and Knossos encounters problem.

Then i opened wxLauncher, chose fs2_open_3_8_0_SSE2
Played the game and IT WORKED !  :D At last i was able to see the new ships in techroom and to play without having slow image per second.
However, it showed me an error messages (different from the one about opengl from my previous posts). Check the image.
Unlike Knossos you have a debug button on the old platform...so after having clicked 5 times on "debug", the game launched and i was finally able to see the new MediaVPs from the techroom.

Therefore... i can safely say that there is something buggy with either FSO 64AVX and Knossos.

Something you didn't answer from my previous posts is why only Knossos 0.8.3 worked while higher version have this error message about opengl.
Maybe a track: I've noticed that (check image) Knossos launcher 0.8.3 has 48 598 Ko while new version are a bit lighter. Maybe you "deleted" something that is no longer in new versions of Knossos and that generate this openGl error. I trully think that there is a bug somewhere in Knossos. And secondly why using Knossos i'm unable to play with the new MediaVPS while using the old platform i can.

From now on i will keep the old platform, not that i like it (i sincerly prefer Knossos looking) but as Knossos new versions don't work, i don't have much choice. Please find what is the root cause to enhance our use of Knossos. :yes:

« Last Edit: October 01, 2018, 11:12:58 am by Bobun »

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
here the 5 error messages i got using the debug button (maybe some tracks for you to resolve the mystery :) )
After the 5th message, the game launched.


 

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Anims: 420, Cutscenes: 10, Mainhalls: 7, Logos: 52
    • Steam
    • Twitter
    • Mix-Hai Productions
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
MediaVPs 3.8.x requires a nightly build. You can get one here.

Knossos currently has a bug that prevents it from getting the required build for the MediaVPs. This bug will be fixed in the next Knossos update. You can fix the problem yourself by going...

Knossos > Settings > Knossos > Preferred Stability > Nightly.
Cutscene Upgrade Project - Mainhall Remakes - MixaelANITools - Between the Ashes - MjnMixael's Render Boutique - Mix-Hai Productions
Youtube Channel - P3D Model Box - Photobucket Albums - Model Releases - Downloads
Between the Ashes is looking for committed testers, PM me for details.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
i did that already...it's not the issue. Check my first posts p23 to understand why i wrote that (take me lot of time to describe in english what is what and it's not easy)

 

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Anims: 420, Cutscenes: 10, Mainhalls: 7, Logos: 52
    • Steam
    • Twitter
    • Mix-Hai Productions
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
You may have multiple issues going on, but I am telling you that one problem is that you cannot run the MediaVPs with FSO 3.8.0. The five errors you posted are because the FSO 3.8.0 does not understand some of the newer options in the game_settings.tbl in the MediaVPs. Use a nightly and then we can figure out the other issues.
Cutscene Upgrade Project - Mainhall Remakes - MixaelANITools - Between the Ashes - MjnMixael's Render Boutique - Mix-Hai Productions
Youtube Channel - P3D Model Box - Photobucket Albums - Model Releases - Downloads
Between the Ashes is looking for committed testers, PM me for details.
Report MediaVP issues, now on the MediaVP Mantis! Read all about it Here!

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
mjn.mixael i have the impression that you don't understand what im saying or my approach. I don't throw stones at you as my English writing is not perfect, therefore my message is maybe not clear enough. Trying to make it clearer  :) My approach is to give you details and context for you to improve Knossos (i really like this platform). Im not here to make you loose your time but to give feedback that will participate to the common good.

Quote
MediaVPs 3.8.x requires a nightly build. You can get one here.

Quote
You may have multiple issues going on, but I am telling you that one problem is that you cannot run the MediaVPs with FSO 3.8.0.

I know i have multiple issues, my 1st post on page 23 tried to carry your attention on 2 issues i encountered: one with Knossos and another one with MediaVPS+FSO.
I know also that MediaVPS need nightly versions, it's what is said here https://www.hard-light.net/forums/index.php?topic=94988.0, and previously since page 1 of this subject.
I did that already.
In addition to find out what could be at the root of these 2 different issues, i did tests (page 23) with different configuration of Knossos and FSO (stable, RCs or nightly). Results are detailed page 23.

Quote
The five errors you posted are because the FSO 3.8.0 does not understand some of the newer options in the game_settings.tbl in the MediaVPs. Use a nightly and then we can figure out the other issues.


The 5 error message, i posted them to illustrate the fact that
with Knossos 0.8.3+Mediavps 3.8.1+FSO nightly=can't see ships in techroom
with FreeSpaceOpenInstaller.jar+Mediavps 3.8.1+wxlauncher+FSO=CAN see the ships in techroom. This is an improvement and means that the issue i first posted on page 23 (about Mediavps 3.8.1) is "partly solved" (only in debug mode) using FreeSpaceOpenInstaller and wxlauncher.
I shared this with you to give you tracks to find out where the issue could be.

But like i said this is not the BIG issue. Like i wrote in my 1st post (page 23), big issue is with Knossos.
Knossos 0.8.3 works fine on my computer, apart from the mediavps 3.8.1 issue.
But each time i use a higher version of Knossos (the updates) from 0.9.1 to the last 0.12.4, after the update i can't open Knossos and i have the error message about opengl.
But again, there is no opengl problem on my computer, my drivers are up to date and are compatible with opengl 4.5. This has been checked with Ngld previously.
Therefore, if my opengl is fine why im having this odd error message each time i use Knossos 0.9.1 and higher? while i don't have this error message at all on knossos 0.8.3.
I don't understand this, that's why i think that maybe something (a dll or whatever) shall be present on knossos 0.8.3 and not anymore with the new versions. That was what i wrote previously today.

The other thing i don't understand is why there is "no more issue" (i can use the mediavps 3.8.1 and see the new ships in techroom) using wxlauncher and  FreeSpaceOpenInstaller.jar while using Knossos with nightly make it impossible to see any ships in techroom. That a new thing (from my test of this weekend). If we find out why is that maybe we can understand the root cause of this situation to enhance Knossos.

Is it clearer?
Sorry for the long text...i had the feeling that you were taking a wrong path in focusing your attention on "my 5 error messages" while it's not the problem.

Cheers :)

Edit: something new:
I extracted the nightly files into C\Games\FreeSpace2
I observe that some dlls installed from FreeSpaceOpenInstaller.jar have been improved with the nightly version (larger size dlls).
Use wxlaucher and nighly 2018-10-01 11f9175 sse2 64bit: same issue described before, can't see any ships in techroom.

Since the nightly gave me new larger size dll, i check how previous fs2 open 3.8.1 would react.
Use wxlaucher and FS2 open 3.8.0 SSE2 64 bit: 5 error messages (debug button) but CAN see the ships in techroom. It's a good news since previously there was this error message "the application failed to start correctly (0xc000007b)"

Use wxlaucher and FS2 open 3.8.0 SSE2: i have the error message "the application failed to start correctly (0xc000007b)"... weird since previously this version was working fine (apart the 5 error messages on debug, i was able to see ships in techroom) before extracting the nightly version.

« Last Edit: October 01, 2018, 03:36:36 pm by Bobun »

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
The 0xc000007b error is caused by mixing 64 exe and DLLs. In the case of wxLauncher you put both the 32bit and 64bit build in the same folder which can't work (and will never work). This is a known fact and nothing we can do about that. It's also unrelated to Knossos. If you get the same error with Knossos, it's a completely different problem.

The other issues sound like various OpenGL issues. My guess would be that your computer is using the Intel HD graphics card instead of the Radeon when launching FSO through Knossos since there shouldn't be any difference with the way FSO renders stuff regardless of whether wxL or Knossos are launching it.

The smaller size of the newer Knossos versions is due to the fact that they don't include ANGLE (which can rewrite the OpenGL calls into DirectX calls). As a result Knossos won't work on machines which don't support modern OpenGL versions, however on those machines FSO won't work either. This further confirms that there's something fishy going on with your graphic drivers. Probably the same issue. Can you force your computer to use the Radeon for Knossos and everything it launches?
Note, I didn't intentionally "delete" anything. The installer is built using an automated process and some part of that changed. I can look into fixing this and providing the missing DLLs but as I said before if you have working (modern) graphics drivers, Knossos should work fine.

EDIT: Reread previous posts and fixed some statements.
« Last Edit: October 01, 2018, 04:38:14 pm by ngld »

 

Offline Bobun

  • 24
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
thanks for the answer mates (ngld & mjn.mixael), i really apreciated ;)

Quote
The 0xc000007b error is caused by mixing 64 exe and DLLs. In the case of wxLauncher you put both the 32bit and 64bit build in the same folder which can't work (and will never work). This is a known fact and nothing we can do about that. It's also unrelated to Knossos. If you get the same error with Knossos, it's a completely different problem.

ok i will try to reinstall things again.

Quote
The other issues sound like various OpenGL issues. My guess would be that your computer is using the Intel HD graphics card instead of the Radeon when launching FSO through Knossos since there shouldn't be any difference with the way FSO renders stuff regardless of whether wxL or Knossos are launching it.

Seems logical and i though too that something like that could be the root cause.
So before posting my first post on the forum (page 23), I configured the switchable graphic to use Radeon card with Knossos and FSO stable an nightly version. All my tests were done with that too.

Quote
The smaller size of the newer Knossos versions is due to the fact that they don't include ANGLE (which can rewrite the OpenGL calls into DirectX calls). As a result Knossos won't work on machines which don't support modern OpenGL versions, however on those machines FSO won't work either. This further confirms that there's something fishy going on with your graphic drivers. Probably the same issue. Can you force your computer to use the Radeon for Knossos and everything it launches?
Note, I didn't intentionally "delete" anything.

yes, thanks mate for the explanation :). I hope you didn't take it wrong, i though that maybe something could be missing between my knossos version and the update version...that could have explained things.

If it's my driver, i will be stuck with it, there won't be any updates with these switchable cards (they are final in my case). If i change my computer, i shall have modern drivers.

Thanks guys for your efforts, answers and explanation. Long live Knossos! :)

 
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
Very slick and handy. However not a single campaign/mod I've tried has successfully launched. I get as far as the main menu (after warnings and alerts that errors were detected) and then the whole thing comes crashing to desktop. So far, the original Inferno is the only one that's worked without a hitch through Knossos.

Now I'm not new, I've checked file integrity and uninstalled/reinstalled mods several times through the Knossos client, no effect. Does anyone have any thoughts? I'm running out of ideas. I'm running the latest version, 0.12.4...
Stardust, the Sword of Vengeance[A starship combat addict]

 

Online PIe

  • 27
  • GTVA POLICE
    • freespace3.com
Re: PUBLIC BETA: Knossos 0.12.4 (combined launcher/installer)
There were some server-side problems recently that should be fixed now.
[6:23 PM] PIe: why do I have the feeling that I shouldn't be able to give orders to 22nd armored hq
[6:24 PM] Axem: 22nd armored hq, i order you to get me a cup of coffee
[6:24 PM] PIe: and donuts
[6:24 PM] PIe: BECAUSE THIS IS THE GTVA POLICE
[6:25 PM] Axem: :O
[6:25 PM] Axem: am i under arrest
[6:26 PM] [`_`]/: no, just please step out of the myrmidon
[6:26 PM] [`_`]/: you have so much to fred for