Author Topic: Release: Mantle 1.0.0  (Read 12447 times)

0 Members and 1 Guest are viewing this topic.



Mantle 1.0.0 is now available on Knossos! See bottom of post for download.

In this fourteen-mission campaign, you'll get a chance to play as a pilot serving on a Hammer of Light destroyer which, by misfortune or providence, becomes trapped in Shivan territory. Faced with peril both mortal and spiritual, will you and your allies have the fortitude to survive?

Screenshots:













Major changes:

- New Hammer of Light variants for the ships and weapons used by Runihara Cell. Hammer of Light textures for the Typhon, Aten, and Sekhmet were made by Galemp; the rest were hacked together by me.
- The experience of playing the first three missions no longer so closely resembles the experience of pulling out one's teeth through one's digestive tract.
- Various other balance tweaks and writing edits.
- Probably some other things I've forgotten about; I did most of this about a year ago.

Mantle 1.0.0 requires Blue Planet Complete, MediaVPs_2014, and SCP 3.8.0-2.

Please alert me to any issues you encounter.

Credits:

- The Blue Planet team and its contributors, for assets and music used.
- The MediaVPs team and its contributors, for models and textures used.
- Galemp, for Hammer of Light Typhon, Aten, and Sekhmet skins.

« Last Edit: November 17, 2018, 07:58:41 pm by Kestrellius »

 
 :yes: :yes: :yes: :yes: :yes:

Downloading BPC right now so I can't play it at the moment but I just want to say that I've got some nice memories of this campaign. To anyone reading this, definitely have a go at this mod, you won't be disappointed.

And two questions: will it function with MediaVPs 3.8.2 instead of 3.7.2? And is only the 3.8.0-2 FSO build required or it will work with latest nightlies?
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 

Offline QuakeIV

  • 28
At least on Knossos, the first mission doesn't let me use afterburners.  Is that intentional?  I don't think the briefing mentions anything about it.

 
At least on Knossos, the first mission doesn't let me use afterburners.  Is that intentional?  I don't think the briefing mentions anything about it.

The Anubis doesn't actually have afterburners, presumably because of Vasudan budget cuts or something.

 

Offline QuakeIV

  • 28
Ah, thats just me herping the derp then.  Saw the engine energy bar and got confused.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Highlighted! :yes:  This has gotten good reviews; I look forward to playing it.

 
they like you to die as shivan goober5000

 
Hm, I get 13 warnings at start. 1 comes from BP, but rest from Mantle.
https://fsnebula.org/log/5bf546dccb0d333375a851ff

 
I also get the 13 warnings.  Didn't really run into any bugs until mission 7 (The Bitter Scroll).  Everybody warps out, and I get the command to return to the fighter bay...but I fly into the fighter bay and nothing happens.  No option to warp out either, so I can't proceed past that mission.  Really enjoyable campaign so far though!

Also, fun fact...if you accelerate time until the Demon gets in beam range, the Apocalypse will absolutely destroy it.

 
@bug reports:

I'm away from home at the moment, but I'll be back on Monday or Tuesday. Once I return I'll sort these issues out and release the fixes.

 
Okay, finished it. Just as I remembered, it's revolving around an interesting concept and has got some good moments (plus the writing isn't half bad), but a bit... rough around the edges. There are the warnings, default loadouts are nothing more than lol, first couple missions don't really make too much sense, and mission backgrounds are quite... deserted. I have also experienced crashes - last two missions were especially notable of that, other ones were much much more stable. I will PM you a more detailed nitpicking text, Kestrellius :P.

As for warnings, the campaign is definitely playable in its current state, but you may come across some instability. I played the campaign on a FSO nightly from 7th Nov instead of 3.8.0-3 release so that might be causing the issue. Just in case I've uploaded a debug log (made on 3.8.0-3): https://fsnebula.org/log/5bfb3637cb0d33337aa851ff. I've also attempted that on the nightly I played it on, but after the first error (the BP-related one) is displayed I can't click on any of the Debug/Continue/Exit options, since regardless of where I click, everything FSO-related gets "alt-tabbed", so it seems like some problem with Windows/FSO communication.

@theperfectdrugsk:
Mission 7 (The Bitter Scroll) is playable for me, both from the Tech Room and normal campaign progress. I guess flying into the fighterbay might be a little bugged - maybe only one of the entrances is taken into consideration? I've also noticed that this mission actually needs you to fly into the fighterbay entrance a bit deeper than other ones, I guess this might be somehow related to the problem. Maybe the mission doesn't really detect you properly if you don't fly right in the center of fighterbay's entrance?
As for the Demon, this mission doesn't predict that you'll stick around to see the fight, so it has a several quite big issues with it. For one, no fighters, bombers or additional warships are involved in the battle, and both destroyers don't attempt any battle maneuvers which leaves them in really poor positions. The Apocalypse doesn't have a way to bear both heavy beams on that Demon at the same time (aren't these cannons on completely different sides of the ship anyway?) and the enemy destroyer has that stupid angle of approach that its two main beams have the Apocalypse just a bit outside their field of view until they park alongside each other. At first glance I thought Demon's beams are just locked but the smaller one on top did actually fire.
And even not accounting other forces, the Apocalypse has got very slim chances of surviving the fight since it is already damaged by enemies from earlier and that Demon can wreck it with a single beam cannon in a bit above 30 seconds even when being bombarded by that Vasudan beam for quite a while.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Okay. So, something here is borked. The loadouts you're seeing are definitely not supposed to be what they are, and you're meant to have access to the HoL weapon variants (meaning the red Prometheus, HL-8, and yellow-exhaust variants of the Tempest and Cyclops) in all missions where the retail versions are available.

Now the thing is, none of the things I just mentioned are appearing on my end. When I run Mantle from the Knossos mods page, I get no warnings (unless I'm running debug, anyway). The loadouts are as I remember them -- no Akhetons, and the missile racks are full. Oh, and Mito, there were a couple of suggestions you made -- the Ganymede in Mission 1 not having a shockwave, and the enemy ships at the end of Mission 4 warping out when damaged -- that are already supposed to be there. And they seem to be, in my version. I'm less sure about the Ganymede explosion, but the fighters in Tribulation definitely leave when damaged enough.

So...you guys have a different version of the mission files, for some reason. Apparently one in which my custom weapons are missing from the default loadouts. I'm not really sure why that's happening, but maybe uploading it again will help? I'll work on this more tomorrow; it's pretty late here.

Anyway. So, there's certainly stuff to fix and tweak -- the retail variants of weapons I've made HoL versions for shouldn't even be available, for one, since that's just confusing; and I don't seem to have paid enough attention to missile counts in a few cases -- but the majority of the issues being reported don't show up on my end, so I should be able to fix them in one fell swoop if I can figure out why it's happening.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
I've also attempted that on the nightly I played it on, but after the first error (the BP-related one) is displayed I can't click on any of the Debug/Continue/Exit options, since regardless of where I click, everything FSO-related gets "alt-tabbed", so it seems like some problem with Windows/FSO communication.
That's an SDL bug. 3.8.0-3 is not affected since it uses an older version of SDL.
To get around it, you can go to FSO settings > Dev Tool and enable "Disables interactive dialogs". That'll just skip all dialogs. You probably shouldn't keep that option enabled for obvious reasons.

 
Oh, thanks for the info. As for Mantle, I'm waiting for the reupload on Knossos (you could probably just make a new version to download) and then I will check out if these issues still persist.

Actually, I've noticed that if I launch a mission from the tech room, no loadout issues show up and everything is pefectly fine (using 3.8.0-3). Using 3.8.1-20181107 nightly, only the first mission has got a borked loadout when launched from the techroom, the same happens for it when launched through Continue campaign. The hell?
« Last Edit: December 07, 2018, 01:53:15 pm by MitoPL »
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Something weird is going on with my loadouts.  Am I supposed to still only have access to the Akheton and Rockeye by the 2nd mission?  I'm given the distinct impression that ought not to be the case since I'm supposed to go blow up a convoy.  With limited reload and nothing but an anti-subsystem, that's just not going to work, is it?

Going to try removing the mod and reinstalling, but here's my debug spew, if it is of any help.
https://fsnebula.org/log/5c1732a4cb0d3328fffd57ed

Really enjoying the dialog from the POV of fanatic zealot aliens!
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov

 
That's definitely not supposed to be happening. Something appears to be broken. It's all fine on my end, so I've tried reuploading a couple times, but I'm not sure what's going wrong.

Well, I do need to check if something's wrong with the campaign weapon permissions. That might be the cause of the loadout issues, and I might've missed it. But I'm reasonably certain there's something else going on.

 

Offline Iain Baker

  • 28
  • 'Sup?
    • Steam
    • Twitter
    • NOMAD's Reviews
I had this too. Most of the NPC wingmen appeared to have them too, although somehow theirs appeared to be able to kills things, unless they were finishing them off with secondaries, I couldn't be sure.

Also happens in the third mission.

By the fourth mission - in the subspace corridor - I had (Green) Prometheus cannons. I figured that this was deliberate, since the raid on the station was in part to obtain better weapons. "Ah, we stole some decent primaries, so now they are equipped and I can start blowing things up." I thought. Guess I was wrong.

PS - this also suggests that on normal difficulty at least, you can complete the first three missions by being a spectator 90% of the time.

PPS - Not sure if this is related or not, but my copy of BP had a game braking glitch during 'The eye of the storm' mission (The tower defence of the refinery mission), whereby the mouse stopped working for flight control after placing the tanks. Worse, even if the mission was completed successfully, the debrief screen said mission failed, preventing me from progressing the final mission. Could a bug from my BP install be causing other issues with mods that are based on it? Would a complete delete of everything BP related and reinstalling it all fresh help?
« Last Edit: December 17, 2018, 12:39:56 pm by Iain Baker »
Wanna check out my video games, technology and media website? If so, visit; https://www.nomadsreviews.co.uk/

Interested in hiring my freelance writing, proof-reading, editing, SEO, TTSO, Web Development or Social Media Management services? If so, please visit; https://iainbakerfreelance.co.uk or https://www.fiverr.com/ibfreelance

 
Since the topic has awakened, I'd like to point at the addendum in my earlier post. Also, could anyone check if the weapon loadout problems persist on different builds or when launching missions from the Tech Room?

I guess that at some point you maybe tried to give players access to new weapons based on their performance in earlier missions or something. IIRC, this could only be done via editing mission/campaign files with Notepad or a similar tool and maybe something went wrong.
Mito [PL] - Today at 8:52 PM
I was supposed to make a short presentation about basics of optical fibers and here I am, listening to Eurobeat while reading about quantum cryptography.

 
Not quite. So, in the original release, everything was just vanilla weapons. (Well, some of them were altered by BP, but you know what I mean.) This included green Prom Rs, as the starting weapon. When I started modifying assets to make them more HoL-appropriate, I eventually decided to create variants of all the weapons that didn't have red, orange, or yellow effects. (Well, except the Akheton, but nobody cares about the Akheton and it's never really used in the campaign. Also I forgot it existed.)

So I made a Hammer of Light variant of the Prom R, which shoots red bolts. You are supposed to be, by default, equipped with this red Prom R in all of the first seven missions of the campaign -- up until you
Spoiler:
retrieve the supplies containing Mekhus from the Revelation and Witness in Mission 7, "The Bitter Scroll".

Now, in the version I released last month, I left the original, non-HoL variants of all those weapons -- including the green Prom R -- as options in the mission loadouts. I figured giving the player extra options couldn't be a bad thing. In retrospect, this was a stupid decision -- it just creates pointless confusion, especially since I'm not even sure it's possible to tell the variants apart in the weapon select screen.

So, in the version that I uploaded (or at least tried to upload) a couple days ago, I fixed that -- the mission loadout options only give you access to HoL variants.

But for some reason the version you guys are getting is different from the version I uploaded. (Both times. Borked loadouts involving Akhetons were never part of anything I uploaded.) It sounds like what's happening is that my HoL weapon variants are missing from the mission loadouts for some reason, which is why they only appear in the red-alert missions -- in those cases they're forced in by the mission's red-alert status. As for why they'd be substituted with Akhetons...my guess would be that it's because you're required to have at least one primary weapon, and...maybe the Akheton comes first alphabetically...?

Based on some other things Mito said, I think what might be going on is that the game is using old mission files, from the original release. (But maybe only partially, or something? If the old missions are being used, the weapon variants shouldn't be present in the red-alerts, either. It kind of sounds like the game is trying to mash the two versions of the missions together, but I don't know how or why that would happen.)

For reference, could you guys tell me some other things about the missions you're getting? Specifically, what color are things? All of the HoL ships, from warships to fighters (with the exception of the Bes-class Witness), are supposed to have red glows, rather than the original blue. Which are you seeing? If they're red, are all of the ships red, or is it just the Typhon and Aten, with the others still being blue?

Similarly, what do the blobs from the HoL's turrets look like? They're supposed to start yellow and gradually turn red, as well as having a slightly different texture from the standard blobs. Do they look like that, or do they look like the normal ones? (Or are they starting-yellow-turning-red,  but still using the regular textures -- the way they look in the OP's second screenshot? I ask because the different texture was a very late addition, so if you're seeing an intermediate version that might shed light on what's happening.)

I really do apologize for how much a ****show this is. Unfortunately I'm genuinely not sure what's going on here or how to fix it.

 
HoL ships have the red glows both in mission and in the Tech Room, from what I see.  The HoL cruiser seems to be shooting yellow stuff fading into orange / red.  The beams look more orange than typical Vasudan beams.

I've tried multiple different builds from nightlies all the way back to 3.8.0-2, but it doesn't seem to make any difference.  (I don't get all the error messages in the earlier release builds, but I can't tell that those are actually related to the real problem or not.)

I did install the first 1.0.0 version of Mantle from Knossos when it came out, but I didn't get a chance to play it until 1.0.1 came out (at least not that I remember!).  Installed 1.0.1 on top of it.

I have uninstalled the mod, reinstalled it, but that didn't make a difference.  Tried switching to a different back-up pilot in case my pilot file was corrupt, but that also made no difference.  This is definitely a weird one.  Let me know anything you'd like me to try.  I'm not very experienced at detailed debugging, but I'd like to help any way I can.
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov